Faulty LED flash on my Nokia Lumia 920?

| November 17, 2012 | 91 Replies

 

I just got back with my friends from a night out, testing the Nokia Lumia 920 on the way and for some reason, the LED flash does not want to work anymore. My phone is not even 2 days old.

It may just be a bad batch. It might be some software issue. I know that the LED light apps I tried would not switch the LED on prior to tonight but the LED flash was definitely working as you can see the red eye in the pictures I took earlier.

What’s going on huh? Also I noticed, the flash bit seems to be a little too easy to press and move. Say what?

It’s a good thing the 920 is not designed for flash pictures. But still, what an inconvenience. I also opted not to have the Phones4U instant replacement insurance because I didn’t think I’d need it (and there’s some house insurance). It’s within their 14/28 day guarantee thing so I guess I can get a replacement.

No, the 920 has not been dropped or had anything spilt on it or any damage or whatever. It’s pristine. As mentioned, it’s barely over a day old in usage. Everything else works fine. Not that it should even be a problem as my 900 has had several drops and functions like it’s brand new.

BTW, the 808 is still the phone to take pictures on a night out. The 920 is great and probably better than other LED based phones but 808 really does wipe the floor with it. Fact. Although I do like having a smartphone platform I’m comfortable with and for the same phone to be able to take some okish low light flash pics.

Category: Lumia, Nokia

About the Author ()

Hey, thanks for reading my post. My name is Jay and I'm a medical student at the University of Manchester. When I can, I blog here at mynokiablog.com and tweet now and again @jaymontano. We also have a twitter and facebook accounts @mynokiablog and  Facebook.com/mynokiablog. Check out the tips, guides and rules for commenting >>click<< Contact us at tips(@)mynokiablog.com or email me directly on jay[at]mynokiablog.com

Comments (91)

Trackback URL | Comments RSS Feed

Sites That Link to this Post

  1. Poledog says:

    I’ve the same problem with my LED flash. Completly dead after one week. No drop of the phone at all.

  2. Sam says:

    Same issue. This is my second bad 920. First one had a bad proximity sensor so I couldn’t touch the phone during a call. I’m thinking of HTC at this point.

    • kgrandpak says:

      Just a call from Nokia the other day and they said they were going to send me a new phone free of postage, we’ll have to see if it is any different.

  3. Niederlenz says:

    Mine is about 1 month old,the light also stopped working for me, its very annoying.

    • cornz says:

      Same here, new 4 week old 920. flash stopped, no focus light, no flash, nothing. soft/hard resets made no difference.
      Will take me a week to set it all back up when new one arrives.
      Grrr….

      • RhClarkKent says:

        When Nokia replaced your phone did you have to send in the faulty faulty phone before or after you received a new one? I don’t want to be without a phone for weeks while the wait to get my faulty device.

  4. Kenneth Ikkeheltvanlig says:

    Having same issue, L920 just bought, likely whole different batch or even version. Flash worked fine both in cam and apps earlier today, then now when I need it, it’s dead. Soft reset didn’t help. Luckily, local laws guarantee a replacement but still blows because 920 might be the prettiest phone I’ve ever had, so I won’t change

  5. JBone says:

    I fixed my 920 LED flash issue. http://www.youtube.com/watch?v=cKd8tCAH-eY watch that vid to figure out how to take the case off.

    Take the sim card out first then carefully take off the case.
    Then lightly scuff up the contacts, and copper contact pads that are located around the camera and LED lights with the tip of a tiny flathead scewdriver. I found one contact prong that seemed to be slightly flattened out, I re-bent it up just a little to match the other. Again be very careful.

    Put it back together put the 2 bottom screws back in, sim card back in. then turn it on and test.

    For me it worked the first time, camera flash and flashlight apps work flawlessly once again. Took about 15 minutes total.

    Or you could send it back to nokia………..no thanks

  6. Same problem. My l020 is four months old. I’ve already sent it to the Nokia Care Centre twice. Each time they fix it – it stops working again.

  7. yaksplat says:

    Thanks jbone! Worked like a charm and a quick 5 minute fix.

Leave a Reply